
Date Area Description Details

Build 28.0.0.41 - March 2019 Billing New filtering options when preparing for bills When preparing for billing, you can now include only those clients with billable 

charges. On Pre-bill Worksheets or Totals Only Worksheets (select Reports > Billing), 

unmark the new "Include bills with activity and no billable charges" option; on Billing 

Assistant (select Bills > Billing Assistant), use the new "any billable charges" rule.

Build 28.0.0.41 - March 2019 Billing Generation of Bills Completed shows additional information. After printing bills (select Bills > Generate Bills), the Generation of Bills Completed 

dialog box shows information about the bill run. This screen now shows additional 

totals, such as number of bills that will be sent by email and the number of clients 

with no data.

Build 28.0.0.41 - March 2019 Database 

Maintenance

Data Summary provides an overview of database contents The Data Summary (select Special > Data Summary) provides an overview of your 

database, including number of slips, transactions, clients, reference, bill images, etc.

Build 28.0.0.41 - March 2019 Database 

Maintenance

Review logged-in users When you have security set up (select Setup > Security > Security Settings), 

supervisors can use the new Logins page to audit database access. Use this list to 

review when other logins accessed the database, the application they used, and the 

name of their workstation.

Build 28.0.0.41 - March 2019 Database 

Maintenance

Display Firebird information in TSAdmin You can use Timeslips Administrator (select Special > Timeslips Administrator) to 

troubleshoot problems in Timeslips. When you click Diagnose This Computer, the 

Firebird Database Engine section now shows the version of Firebird you are using.

Build 28.0.0.41 - March 2019 Reports Additional searching available for Name Filters When using name filters to filter the contents of a report, you use the new Find field 

to limit the timekeepers, clients, tasks, expenses, or references displayed. Type a 

few characters in the Find field and the name list will show names that include the 

search string anywhere in the nicknames or full name. You can mark those you want 

to include in the report.

Build 28.0.0.41 - March 2019 Reports View a specific page of a displayed report When printing reports to Display, you can now use controls in the bottom left to 

jump to a specific page of the report. In previous versions you had to move through 

the report one page at a time, but now you can scroll through the report or jump to 

a specific page.

Build 28.0.0.41 - March 2019 Slips Duplicate one slip to many clients Some firms often make duplicates of current slips and assign them to other clients. 

You can now speed up this process. From the Time and Expense Slip List (select Slips 

> Time and Expense Slips), right click on a slip and choose Duplicate to Multiple 

Clients.

Build 28.0.0.41 - March 2019 Slips Additional details available when managing active slips For firms that use the stopwatch to time slips, the Stop Timers dialog box (select 

Slips > Stop Timers) now includes more information to help you manage active slips.

Build 28.0.0.41 - March 2019 Transactions Simplified invoice payment When you receive a payment from a client, there is a new shortcut to speed up the 

entry in Timeslips. From the Accounts Receivables List (select Transactions > 

Accounts Receivable), right click on the invoice being paid and choose Pay This 

Invoice. Timeslips will start a new payment, filling in many of the fields for you.
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Build 28.0.0.41 - March 2019 Transactions Simplified reverse payment If you have to reverse a payment from a client, there is a new shortcut to speed up 

the entry in Timeslips. From the Accounts Receivables List (select Transactions > 

Accounts Receivable), right click on the payment being reversed and choose Reverse 

This Payment. Timeslips will start a new reverse payment, filling in many of the fields 

for you.

Build 28.0.0.41 - March 2019 Transactions Additional totals on Accounts Receivable List The Accounts Receivables List (select Transactions > Accounts Receivable) now 

shows totals for Debits and Credits below the list.

Build 28.0.0.41 - March 2019 Transactions Apply credits to open invoices When you enter credits, the Apply All button is available, which can apply the credit 

amount to multiple open invoices at the same time.

Build 28.0.1.96 - August 2019 Billing Password-Protected Bills and Statements You can now password-protect bills and statements printed to PDF, so unauthorized 

viewers cannot open them. To assign a password to a client, select Names > Client 

Info > open a client > Invoices > PDF Password. You can also assign a global 

password for your firm, so you can view the PDFs without having to remember each 

individual password. To assign a global password, select Setup > PDF Setup > 

Security.

Build 28.0.1.96 - August 2019 Client Funds Replenish Funds Email You can now email a funds replenishment request directly to a client at any time. Go 

to Transactions > Send Funds Replenishment Emails to show which clients are below 

their minimum funds balance. From here, you review when you last requested funds 

replenishment and send an email to them.

Build 28.0.1.96 - August 2019 LawPay Support for LawPay eChecks When a customer submits an eCheck in LawPay, that transaction is now available as 

a source for a new payment in Timeslips. In Timeslips, go to Transactions > LawPay 

Transactions to review LawPay transactions and act on them.

Build 28.0.1.96 - August 2019 LawPay Provide new tokens for LawPay messages that include 

replenishment amounts

There are now two additional tokens available for emails:  (1) LawPay Link with 

Invoice plus Replenish Amount; (2) LawPay Link with Balance plus Replenish 

Amount.  These new tokens reflect values that take into account when a client must 

replenishment their client funds.

Build 28.0.1.96 - August 2019 Lists Customize Columns on Name Lists You can now change the fields that appear in Name Lists:  Timekeeper List, Client 

List, Task List, Expense List.  This can make lists more useful, showing fields that are 

more important to you.  For example, for clients, select Names > Client Info > click 

the List Appearance Options toolbar button to choose which fields to show in the 

list.

Build 28.0.1.96 - August 2019 Lists Print from Name Lists You can now print a quick list of names from name lists.  You can now print a quick 

list of names from name lists.  For example, for clients, select Names > Client Info > 

click the Print List toolbar button. The printed report will reflect any columns you’re 

showing and the current sort order applied to the list.

Build 28.0.1.96 - August 2019 Lists Searching Name Lists You can now search on any of the displayed columns in a name list.  You can now 

search on any of the displayed columns in a name list.  For example, for clients select 

Names > Client Info; if the search bar (labeled Find) is not displayed, click Show 

Search. Enter the text you want to find and the list will show any matches.

Build 28.0.1.96 - August 2019 Slips Restrict Slips After A Date You can now restrict slips that were entered after a specific date. For example, you 

may not want slips to be entered for future dates, so you can restrict dates entered 

after today, or after this week, or after this month. Go to Setup > General > Slip, A/R, 

and Funds to get to this new setting. It is named Do not allow saving slips with a date 

after. You can use a static date or a relative date (a relative date makes more sense).



Build 28.0.1.96 - August 2019 Slips Add Time Spent to the Stop Timers dialog box The Stop Timers dialog box (select Slips > Stop Timers) now shows the Time Spent 

for running timers. This is useful to verify no timers were left running by mistake.

Build 28.0.1.96 - August 2019 Slips Show the Stop Timers dialog box when timers meet threshold You can now set a time threshold for running timers. When Timeslips starts, if any 

slips with active timers meet the threshold, the Stop Timers dialog box (select Slips > 

Stop Timers) opens, allowing you to act on active timers. This helps you avoid 

runaway timers and inflated slip values.

Build 28.0.1.96 - August 2019 Slips Mark Slips as Exported This enhancement simplifies the process of marking slips as Exported. Before 

printing a user-defined slip listing, open Options and set the new When exporting, 

mark slips as Exported option.

Build 28.0.2.123 - November 2019 Reports New Report Types: User-Defined Transaction Reports There are now two new types of user-defined reports available: user-defined 

transaction listing (which can show details from each transaction) and user-defined 

transaction summary (which can summarize totals for all included transactions). 

Both reports are available with Client reports (select Reports > Client). These reports 

can show data fields and totals from time and expense slips, accounts receivable 

transactions, client funds transactions, and clients, and display them in one report. 

Like with other user-defined reports, by choosing data fields, selection filters, and 

sort/subtotal options, you can make a variety of useful reports.

Build 28.0.2.123 - November 2019 Reports New Groups of Report Fields on User-Defined Client Reports When designing user-defined client listing reports or user-defined client summary 

reports (select Reports > Client), there are new groups of fields available to use. The 

fields in the Accounts Receivable Totals section allow you to show a/r transaction 

totals and distribution totals for the transactions included in your selection. The 

fields in the Funds Totals section allow you to show funds transaction totals for the 

transactions included in your selection.

Build 28.0.2.123 - November 2019 Reports New Field: Email Template field is now available on User-Defined 

Client Reports

When designing user-defined client listing reports (select Reports > Client), you can 

add the Email Template to the report. This is useful to quickly view which template 

each client uses when emailing bills.

Build 28.0.2.123 - November 2019 Reports New Report: Client Balance Overview A new user-defined client report is now available with Client reports (select Reports 

> Client). The Client Balance Overview shows the current A/R balance for each client, 

along with the debit and credit totals contributing to the A/R balance. Because this is 

a user-defined report you can easily customize it further to fit your needs.

Build 28.0.2.123 - November 2019 Reports New Report: Top Clients Collected A new user-defined client report is now available with Client reports (select Reports 

> Client). The Top Clients Collected shows the totals payments collected for each 

client. Other details, such as total write-offs, discounts, and credits are available, but 

the report is sorted by total payments. Because this is a user-defined report you can 

easily customize it further to fit your needs.

Build 28.0.2.123 - November 2019 Reports New Report: Slips, A/R, and Funds by Client A new user-defined client report is now available with Client reports (select Reports 

> Client). The Slips, A/R, and Funds by Client report shows totals of each slip and 

transaction type for each month. It’s an easy way to audit the slips and transactions 

entered for each client on a monthly basis. Because this is a user-defined report you 

can easily customize it further to fit your needs.



Build 28.0.2.123 - November 2019 Reports A new user-defined client report is now available with Client 

reports (select Reports > Client). The Slips, A/R, and Funds by 

Client report shows totals of each slip and transaction type for 

each month. It’s an easy way to audit the slips and transactions 

entered for each client on a monthly basis. Because this is a user-

defined report you can easily customize it further to fit your 

needs.

When you are setting up a Client Selection filter on a bill or report, you can now right 

click on a project and choose "Select All Projects Associated with This Client". All 

related projects will automatically be marked for you. This can speed up project 

selection for clients with many projects.

Build 28.0.2.123 - November 2019 Reports Show History Period in Status When you are designing user-defined reports that include client history fields, you 

can choose which history totals to use. For example, one history total could use 

Inception to Date totals and another could use Year to Date totals. When you click 

on those fields in the report designer, you can now see which history total the field 

is using.

Build 28.0.2.123 - November 2019 Support Chat Link is now Available on Mail Menu When using Timeslips, you can now click Live Chat on the main menu to connect 

with Support.

Build 28.0.2.123 - November 2019 Support Access Latest Release Notes from the Help Menu When using Timeslips, you can now access the latest Release Notes from the Help 

menu. Select Help > Sage Support > View latest release notes to review the latest 

changes.

Build 29.0.0.42 - March 2020 Billing Billing Cycle: Undo Multiple Bills If you need to change details on a client's bill, in previous versions you were able to 

undo only the last approved bill. Now, you may be able to undo multiple bills for that 

client. Select Bills > Undo Multiple Bills to open the Undo Multiple Bills dialog box.  

This undo process provides images of any bills you undo. It also includes details such 

as the slips, transactions, and billing arrangements included on the original bills to 

make it easy for you to re-bill your client.

Please note that only bills generated after build 29.0.0.000 will be available to undo 

with this feature. You can see which build was installed for each bill run on the 

Review Bill Runs dialog box (select Bills > Review Bill Runs).

Build 29.0.0.42 - March 2020 Search Find and Replace You can use Find and Replace to search for text within many areas of Timeslips and 

replace it with other text. For example, a client may have changed its firm name and 

you want to quickly change that name in slip descriptions, payment descriptions, 

and other areas. To search for text, select Special > Find and Replace to open the 

Find and Replace dialog box.

Build 29.0.1.64 - June 2020 Billing Printing PDF Attachments with Bills When printing attachments with bills, previous versions of Timeslips could only 

include image-based attachments. Timeslips can now also include PDF-based 

attachments.  To access the new option: (1) select Bills > Generate Bills; (2) Click the 

Options button; (3) Optionally mark Print PDF attachments

Build 29.0.1.64 - June 2020 Billing Maintaining Auto Payments when Undoing Bills In previous versions of Timeslips, when you undid approval for a bill that included 

automatic payments from funds, Timeslips would delete those payments. Now, you 

can choose how Timeslips handles that situation.  To access the new option: (1) 

Select Setup > General; (2) Switch to the Slips, A/R, & Funds page; (3) Use the Auto 

Payments options at the bottom of this screen to determine how to handle 

automatic payments

Build 29.0.1.64 - June 2020 Electronic Billing Add Audit House details to the Bill Stages dialog box You can use the Bill Stages dialog box (select Bills > Approve or Clear Bills) to move 

clients through the billing cycle. The pages of this dialog now show the audit house 

(if any) used to export each bill’s data for review.

Build 29.0.1.64 - June 2020 Electronic Billing Specify Format of Quantity field in Audit House Export When setting up audit house templates (select Setup > Audit Houses), you can now 

determine how many decimal places to show for quantity/unit fields.



Build 29.0.1.64 - June 2020 Reports Adding Last Transaction Date to Funds Account Listing When printing the Funds Account Listing report (select Reports > Funds 

Transactions), there is a new option, Show last transaction date. Use this option to 

show the date of the last transaction affecting each of the funds accounts included 

on the report.  To access the new option:  (1)  Select Reports > Funds Transactions; 

(2) Double click on the Funds Account Listing; (3) Click Options; (4) Otionally mark 

Show last transaction date

Build 29.0.1.64 - June 2020 Reports Updating Other Report Fields On user-defined reports, bills, and statements, you can place database fields on the 

report layout and they show values from the database when you print the report. 

Several fields were showing blank values when printing the report.

Build 29.0.2.92 - October 2020 eCenter eCenter Client Access Administration Each account in Sage Timeslips eCenter can share account balances and transaction 

status with up to 100 of their clients. In past versions, you managed access for your 

eCenter clients through the Admin Functions page on Timeslips eCenter. We now 

offer improved management of Client Access directly in Sage Timeslips (select 

Special > eCenter > Manage Client Access). Here you can review all clients at once 

and also change access for clients in batches instead of one at a time.

Build 29.0.2.92 - October 2020 eCenter Show eCenter Information in Timeslips Navigator Each account in Sage Timeslips eCenter can share account balances and transaction 

status with up to 100 of their clients. In past versions, you managed access for your 

eCenter clients through the Admin Functions page on Timeslips eCenter. We now 

offer improved management of Client Access directly in Sage Timeslips (select 

Special > eCenter > Manage Client Access). Here you can review all clients at once 

and also change access for clients in batches instead of one at a time.

Build 29.0.2.92 - October 2020 eCenter New eCenter fields for User-Defined Client Listings When designing user-defined client listings (select Reports > Client), there is a new 

report field available: eCenter Login. There is also a new selection filter: Client Has 

eCenter Login. Using both of these on a report, you can quickly print a listing of 

client logins currently in use for eCenter’s Client Access.

Build 29.0.2.92 - October 2020 Reports New Report: Aged WIP with Contact Info This new report is available within Client reports (select Reports > Client). It shows 

work in process for each client totalled by your custom aging periods. This report 

also includes phone and email information for each client in case you need to 

contact them about their upcoming charges. You can use the report as-is or 

customize it further by adding or removing fields in the Report Designer.

Build 29.0.2.92 - October 2020 Reports New WIP fields for User-Defined Client Listing When designing user-defined client listings (select Reports > Client), there are 

several new WIP-related report fields available. The new Aged WIP group adds over 

30 new fields that you can use to build your own custom Aged WIP reports.



Build 29.0.3.96 - January 2021 Reports Include or exclude Proof slips on slip-related reports When viewing slips on the Time and Expense Slip List dialog box (select Slips > Time 

and Expense Slips) or when printing slip-based reports (select Reports > Slips), you 

can use selection filters to choose which slips to include.

There is now a Slip Proof selection filter so you can specifically include or exclude 

slips that are on Proof Stage.

On the Time and Expense Slip List, click the Selection button to use this selection 

filter.

When setting up slip-based reports, double-click on the report to open Report Entry 

and then use the Selection Filters tab to use this selection filter. This selection filter 

is available on the following reports: Slip Listing, Slip Summary Listing, User-Defined 

Slip Listing, and User-Defined Slip Summary.

Build 29.0.3.96 - January 2021 Reports Include or exclude all Time or all Expense slips on bill-related 

reports

When viewing billing information or when printing bill-related reports (select 

Reports > Billing), you can use selection filters to choose which slips to include.

There is now a Slip Type selection filter so you can specifically include time slips or 

expense slips.

When reviewing billing information on the Billing Assistant (select Bills > Billing 

Assistant) or Firm Assistant (select Bills > Firm Assistant), click Selection to use this 

new selection filter.

When setting up bill-related reports, double-click on the report to open Report Entry 

and then use the Selection Filters tab to use this selection filter. This selection filter 

is available on the following reports: Generate Bills, Pre-bill Worksheet, Totals Only 

Worksheet, Firm Assistant Listing, and Firm Assistant Totals.

Build 29.0.3.96 - January 2021 Slip List View the Time and Expense List by My Week or My Month When viewing slips on the Time and Expense Slip List dialog box (select Slips > Time 

and Expense Slips), there are new ‘View By’ options that let you quickly see slips for 

the current week or for the current month for the logged in timekeeper. From the 

‘View By’ field, choose My Week or My Month. Optionally click Print from the 

toolbar to include these slips in a Slip Listing report.

Build 29.0.3.96 - January 2021 Transactions Show the Running Balance on the Accounts Receivable List When viewing transactions on the Accounts Receivable List dialog box (select 

Transactions > Accounts Receivable) by client, you can include a Running Balance 

column so you can see how each transaction affected the balance.

To view the list in this format, select Transactions > Accounts Receivable to open the 

list, set ‘View by’ to Client, right click on the list and choose List Appearance Options, 

and then set Field Themes to Running Balance.

Build 30.0.0.18 - May 2021 Billing Approve a bill or credit without generating a bill To approve a bill or credit, right-click on the transaction in the list and choose 

"Approve this transaction".  The transaction will not appear on the next invoice for 

the client.

Build 30.0.0.18 - May 2021 Billing Assistant Show nickname 1, nickname 2 or full name in Billing Assistant list From the billing assistant, press "Ctrl + L" to display the list of clients. Right-click on 

the list to show nickname 1, nickname 2 or both.



Build 30.0.0.18 - May 2021 Conflict Checking Additional text for conflict checking During  conflict checks, you can now enter text to search for and Timeslips will 

search for that text throughout the database, along with the Nickname 1, Nickname 

2, or Full Name for the current client or timekeeper.  You can also search for 

conflicts from the Client Information screen using the search icon on the toolbar.

Build 30.0.0.18 - May 2021 Contributions Restrict access and changes to invoice contributions information Security now has the ability to restrict users from changing information on the 

contributions tab of a slip.  Available under the "Billing" section of security rights.

Build 30.0.0.18 - May 2021 Reports Slips Span Multiple Days There is a new report filter "Slips Span Multiple Days".  This is helpful if trying to 

locate slips with a different start and end date.

Build 30.0.0.18 - May 2021 Reports New fields in user-defined client reports New fields in user-defined client reports are: Payments Fees excl Funds, Payments 

Costs excl Funds, Payments Interest excl Funds, and Payments Total excl Funds.

Build 30.0.0.18 - May 2021 Reprint Bills Keep all bill images for a client Client information has an option to keep all bill images for a client.  There is a 

checkbox on the client's "Invoices" page.

Build 30.0.0.18 - May 2021 Slip List View My Slips by Day, Week, Month When viewing slips on the Time and Expense Slip List dialog box using the ‘View By’ 

option, it is now easier to navigate through the dates using the < and > buttons.

Build 30.0.0.18 - May 2021 Slip List Show Source Info on slip list Change the display options to include a column for "Source".  Right-click the slip list 

and choose "List Appearance Options" to add or remove columns

Build 30.0.0.18 - May 2021 System Automatically check for updates There is an option in Preferences to automatically check for updates.  The option is 

located on the Startup and Exit tab of personal prefs (setup … preferences)

Build 30.0.1.54 - August 2021 System What's New Overview After an update is installed, Timeslips provides a screen showing the new features.  

Help > What's New will also show this screen.  It can be turned off in personal 

preferences.

Build 30.0.1.54 - August 2021 System Mail Merge Feature available in Pro and Elite tiers Mail Merge is a feature that was originally only available in Elite but is now added to 

the Pro subscription version.

Build 30.0.1.54 - August 2021 Audit Trail Audit Trail updates Audit trail system has been overhauled.  Security > Audit trails initializes the system.  

Special > Audit trails shows changes to the data.  Data Entry Assistant also was 

updated (Special > Data Entry Assistant).

Build 30.0.1.54 - August 2021 Desktop Save/Restore Desktops From the top menu click Window > Save Current Desktop to save the open windows.  

To restore the desktop, click Windows > Restore Current Desktop.

Build 30.0.1.54 - August 2021 Desktop Fit to Screen The command Window > Fit to Screen will bring dialog boxes back into view if 

monitor configuration has changed

Build 30.0.1.54 - August 2021 Desktop Transaction Entry Colors Screen colors can be set on some of the data entry screens to indicate the 

transaction type (slip, ar, funds) or transaction state (new, saved, editing).  Coloars 

are defined in preferences on the "Colors" tab.

Build 30.0.1.54 - August 2021 System Component Replacement Areas which have been updated are funds entry, save report, custom field entry, 

alert manager, mini slip view.  These areas will be faster and more secure.

Build 30.0.1.54 - August 2021 Backup Scheduled Backup service replaced Scheduled backup service is replaced with a process to create a script which is saved 

and scheduled in system task scheduler.  From Timeslips Administrator click the 

scheduled backups screen.

Build 30.0.1.54 - August 2021 History Bill New Fields for History Bill History bill now can limit transactions based on billed on invoice number and billled 

on invoice date.

Build 30.0.1.54 - August 2021 System Support links on Welcome screen When Timeslips cannot find database, the Welcome to Timeslips screen appears 

including links to "About Timeslips", live Support chat and remote sessions.



Build 30.0.2.63 - Dec 2021 LEDES LEDES 2000 format updated New setup options when exporting bills to LEDES 2000 or LEDES XML.  Some fields 

can be formatted in the export file, and ampersand characters can export as either 

the symbol or the word "and".

Build 30.0.2.63 - Dec 2021 System Connect with Support for Remote Session There is a new platform for connecting with a support representative using th 

eremote session.  Click Help > Sage Support < Support utilities < Remote Support 

Session

Build 30.0.3.71 - March 2022 Lists Ability to increase font size in lists and names To change the font size, click "List Appearance Options" from the toolbar and click 

the "Appearance" tab.

Build 30.0.3.71 - March 2022 Reports New fields in Flat Fee Analysis report The Flat Fee Analysis user defined report has new fields including how a billing 

arrangement affects the client's next bill as well as the ability to create custom 

calculations

Build 30.0.3.71 - March 2022 Client Info Default rate on client info moved The client's default rate is now moved to the top of the Client Info Rates screen 

Build 30.0.3.71 - March 2022 LawPay Option to change name of service AffiniPay is the overall company for LawPay, CPACharge or ClientPay.  Change the 

name to the service your firm uses.  Click Setup > AffiniPay Integration to select the 

name

Build 30.0.5.96  - September 2023 Billing Send bills by emai using Outlook 64-bit Ability to integrate with Outlook 64-bit version

Build 30.0.5.96  - September 2023 Slips Display slip descriptions for individual slips in rows of slip list When viewing Time and Expense slips list, you can change the appearance to show 

the description. Click Slips > Time and Expense Slips; Click Appearance Options from 

the toolbar and mark "Show description on its own row".

Build 30.0.5.96  - September 2023 Slip List Show Daily, Weekly, Monthly views in Slip List You can now quickly change the View of the Time and Expense Slip List to show slips 

By Day, By Week, or By Month for all timekeepers. When using any of these views, 

you can easily move to the previous or next group of slips for that time period.  To 

use these views, select Slips > Time and Expense Slips and change the View By field 

at the top of the list

Build 30.0.5.96  - September 2023 Bill Layout On Project Summary Subtotals section of bills, provide new fields 

to account for Replenish fund

On bills that consolidate multiple projects, new total fields are available in the bill 

designer that account for amounts you're requesting clients send to replenish 

escrow. This ensures the Project Summary totals can match the individual project 

bills.  To edit bill layouts, select Bills > Bill and Statement Layouts and double click on 

a bill layout

Build 30.0.5.96  - September 2023 Reports On the Aged WIP with Contact Info report, there is a new Slip Type 

filter.

When printing the Aged WIP with Contact Info report, you can now filter the results 

to show only Fees WIP or only Costs WIP.  The report is under the "Client" tab of 

reports.

Build 30.0.5.96  - September 2023 Billing 

Troubleshooter

Print report from Billing Troubleshooter When using the Billing Troubleshooter to track potential billing issues, you can now 

print a report with details of each issue found.  To view this report, select Bills > 

Troubleshooter and if any items appear on the list, click the Print button. 

Build 30.0.5.96  - September 2023 Billing Assistant Display the assigned Bill Layout name and Email Template name in Billing AssistantWhen reviewing billing information in the Billing Assistant, you can now see which 

bill layout each client uses to format their bills and which email template each client 

uses to send bills by email.  To view this information, select Bills > Billing Assistant 

and view the Layout / Template information on the Overview page

.


